usb8x required for msd8x
Posted at Sunday, December 7th, 2008 10:38AM by Mapar007

Do I need do install usb8x on my calc before using msd8x? (stupid question, I know, just want to be sure)


re:usb8x required for msd8x
Posted at Tuesday, December 9th, 2008 11:56PM by jbr

Ok, speaking of which, I've got a strange problem:
My cable (male A mini to female regular) seems to check out ok on a continuity tester (the thing on a multimeter that beeps when you connect it to a conductor), but I can't use anything with USB8x. I tried MSD and a mouse today, to confirm, and nothing seems to work.
Shoot, I forget the error messages I get, but I think the one MSD8x gave me was 1208 or something. It isn't the same one I get when I have nothing connected (or the same one I get when I have just the cable connected).

The only strange thing I noticed about the cable is that the shields don't seem to connect. Are they supposed to? I thought USB only had four wires involved?


re:usb8x required for msd8x
Posted at Thursday, December 11th, 2008 11:09PM by jbr

Ok, so it turns out the error message that happens when I actually plug anything in is 1217.

I messed around with it for a while and I was able to get it to work, once, by plugging the mini end cable in half way to the calculator. It worked for about 30 seconds, and then it got pushed in all the way and stopped working.

Of course, that may have nothing to do with it. I had just spent the time before that trying to clean the connector with a rolled up bit of paper, but that probably didn't do anything either.

I'm using a store-bought cable, as opposed to a home-made or modular cable.

I think it all depends on what that error message means, at this point. Could you tell me?


re:usb8x required for msd8x
Posted at Sunday, December 14th, 2008 9:13PM by jbr

Well, I got the same error every time I used it on two separate 84+SEs, so I think the cable is more likely the culprit.
Is it possible, however, that the error in reading the maximum packet size could be the result of the disk drive itself being corrupt or damaged?


re:usb8x required for msd8x
Posted at Sunday, December 14th, 2008 10:13PM by jbr

Ok, yeah, it was the cable. When I twist it the opposite way I usually do (away from the calculator rather than towards it), it seems to work perfectly again.

Now, I seem to remember something about you mentioning OS integration in USB8x, Brandon. Did you mean the openlib/execlib stuff, or something else? Now that I have this working again I'd like to try it out...


reply

You must be logged in to post replies.